Connecting Eurolite Artnet Dmx Node via Wifi Router

Good morning!

I’m having trouble connecting my Eurolite ArtNet Dmx Node 1 with photon via my WiFi Router. The Scenario:

iPad connected via WiFi to the Router, Node connected via CAT6 to the Router.


  • fixed IP-Adress,
  • Subnet Mask:,
  • DHCP off


  • fixed IP-Adress
  • Subnet Mask:
  • ArtNet-Universe 1 (first universe is 1)


  • fixed IP Adress
  • Subnet Mask
  • Photon: Multicast, Subnet 0, Universe 0. Also tried Unicast to, did not work either

Is there somebody who could help me please? Thanks in advance!

Greetings from Germany, Ludwig


Do you have tried to put photon at universe 1 ?

thanks for your answer! i tried, but it did not work. In my opinion Universe 1 on the node and Universe 0 on Photon is right, belonging to the users Manual of the node.

My bad
Artnet universe 1 mean subnet 0/universe 0 in photon
What is your os version, did you allow network request at launch ?

I’m in iPad OS 14.4, iPad Pro 12.9 2015.
Everything is allowed, if I output ArtNet to the PC, everything works just fine. I just cannot output ArtNet to the Node.

Greetings, Ludwig

Just switched the router and tried in the default 192.168.2.x- setting with dhcp on and manual IP on the node. Now everything works as it should.
Thank you VERY much for your time!

Now I’m ready for Photon2 ;D

1 Like

Some nodes has problem with big range networks

Issue resolved, so I :grin:

Photon 2 is on beta on TestFlight :slight_smile: you can beta test this major update