Photon 2.4, 2.5 issues

Hi, I just installed Photon within the last week and have familiarizing myself with the functionality of the application. I was also evaluating Luminair 4, but I much prefer the usability of Photon 2 for building fixtures and overall usability! Kudos!

Unfortunately, I’ve also run into a few issues, and as of this morning, the application isn’t usable on either of my iPads. Here’s a general history of events as I remember them:

  1. Set up Luminair on my iPad Air, set up wireless DMX (Pknight Easynode, ArtNET and sACN enabled) to my GigBAR 2, with cables from the GigBAR to a couple of Rockville LED PARs.
  2. Installed Photon 2.4 on my iPad Air as well. I was immediately able to add my GigBAR 2 from the Chauvet list, and a couple of custom devices for the PARs and use them without issue.
  3. At some point, I lost connectivity with the GigBAR so I decided to do some troubleshooting: Luminair worked. Other shows in Photon worked. ArtNET monitor shows activity. I started deleted the few sequences and scenes I had in the show. Finally, deleting the group with the GigBAR and recreating it fixed the issue and I was again able to control the GigBAR in that show.
  4. I figured out how to export/import shows so I can make some backups :+1:
  5. Photon 2.5 dropped and I upgraded my existing installation. Love the latch and solo feature!
  6. Decided I wanted to use a different iPad (7th generation) so I wouldn’t need to run Photon in the background behind BandHelper during my shows. Installed Photon 2.5 on my iPad and tried to restore a backup from my iPad Air, which crashed the app each time I tried.
  7. Decided to rebuild from scratch on the iPad 7 as I only had a few scenes and one sequence since my issue on line 3 above. Added the GigBAR 2 and my custom fixtures to match what I had on my iPad Air. Made sure I was on the same network, no connectivity to the devices. ArtNET monitor shows activity.
    (Luminair on this iPad works fine) tried different shows, adding only one device… still nothing.
  8. back to the iPad Air… Luminair works. Shows work… "Hmm… I wonder if somehow I had a different Photon setting on my iPad 7. Hit the sACN button on my show on the iPad Air, and instantly dropped connectivity with my devices. no more control.
  9. Switched back to ArtNet… now I have no device control on that setting either! reboot all devices, network, update Pknight device to ArtNET only, reboot both iPads and make sure I’m reconnected to the right network. Neither installation is working. Adding new shows does not correct the issue. Luminair works on both iPads.

I’m considering uninstalling/reinstalling on at least one of these devices to see if perhaps I can get one installation back up and running.

Super frustrating…
The fact that I’m willing to go through this effort with Photon 2 should tell you just how much more I like the UI over Luminair. Even though Luminair has been rock solid, I really don’t like using it. :rofl: I’m looking forward to the day that Photon is stable enough to gig with! Happy to beta test if needed. I’m a software product manager by trade. :+1:

I’d be happy to send diagnostics from each iPad for you if useful.

Update… reinstalled on my iPad 7 and all is working. I still have the iPad Air to test with if needed

Hello and thank you very much for this very detailed feedback.

Regarding the first problem of loss of connectivity. You have to know that when you switch from SACN to ArtNet you lose your preferences and you have to reconfigure the universes and subnet. It is not very intuitive indeed but the problem surely comes from there.

For the rest, we will indeed perform a diagnostic, we will send you a case number in order to retrieve the information from your iPad Air if you don’t mind.

I’m glad to hear that you like the latch mode and that overall you are satisfied with Photon!
For its stability, we are working hard on it and we will make a 2.5.1 to adjust these malfunctions before adding new features.

Thank you very much for your encouragement and your help. Don’t hesitate to share the gigs you make with Photon!

Thanks for the quick response! I’ve uploaded the diagnostic data :+1:

1 Like

We have released today the 2.5.1 version which should fix the problems you have been experiencing. Your shared diagnostic helped us get to the bottom of the problem. Thank you very much for making Photon a bit more stable!

1 Like