Photon 2 cant communicate with Art-Net Node, while Luminair Pro Can

Hello, I have ran into an issue with getting photon to work with my existing setup which I have been using with Luminair no issues. I wanted to try out Photon 2 because I like the one time payment instead of subscription system that Luminair is using. I am using the Pknight Art-Net Node(CR011R) which is connected to a router and to a dmx distributor to control all my lights. I have tried everything to get it to work including, adding node ip into photon 2 settings and making sure its in the same universe and it wont work. With Luminair I never even had to set anything up, my Node lights up blue and everything just works. Please help with this issue.

I do not have the same hardware that you list, but I run Photon 2 on universe 0, and my ArtNet device on Universe 1 and it works. Don’t know why, but what do you have to lose to try it?

Hi, I have found the issue. For what ever reason, it cant communicate in multicast and when I set the ip address, it had to be like this for it to work, 192.168.001.XXX, but another problem also. When putting the ip address in to photon I had to remove the 0, For example on my node the ip address is, but when I put it into photon exactly how it is on the node it wouldn’t work, I had to add it like this, without the 0’s. Also for subnet I left it at although it is recommended to use with ip address starting with 192.168.XXX.XXX, I hope this helps anyone else with the same issue.

1 Like

Or hopefully Photon will fix this issue.

Wish I had seen this earlier I had to figure that out myself. Note I’m trying to program the PkNight wash bar but can’t figure out all the settings to put into photon to get it to let me control all the features. Wish I could get help with that

Hello it is not an issue,

Subnet ( is directed by your network settings and must be identical between the node and iPad and network ip address is not a valid ip address.

Also in multicast and broadcast node, the artnet receiver should react, even if broadcast packets are filtered by one network equipment or subnet setting was wrong

I think the other app has a function to fix mistakes on network settings

But we can add a node discover feature we will study about this

Hi thanks for your reply, I checked and it looks like I did put it in without the 0’s in luminair and forgot, but I was wondering more why, multicast will not work, I will try again and maybe post a video so you can see.